aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbarenblat@galois.com>2014-01-27 15:15:43 -0800
committerGravatar Benjamin Barenblat <bbarenblat@galois.com>2014-01-27 15:17:06 -0800
commitbb3a3a61fe7b971ad8ef326ec7e4d5903e6860ee (patch)
tree1e7cb626e710d0cf1888ee89f45e65afb5b41a13 /Makefile.am
parentecdc86999a7eb30223209887801ec8bbeac1cc9e (diff)
Functional tests for C library
While gearing up to make an addition to the C library, I became concerned at the lack of test infrastructure for the project. The build system now integrates Check <http://check.sourceforge.net/>;, a lightweight testing framework for C, and there are a few tests to ensure no serious regressions occur. You can run the tests with “make check”.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d46630e..d129516 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = include src
+SUBDIRS = include src test
EXTRA_DIST = Doxyfile bindings examples
dist-hook:
$(RM) `find $(distdir) -type f -name .gitignore`