aboutsummaryrefslogtreecommitdiff
path: root/BuildUnix/Gzip/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'BuildUnix/Gzip/Makefile.am')
-rw-r--r--BuildUnix/Gzip/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/BuildUnix/Gzip/Makefile.am b/BuildUnix/Gzip/Makefile.am
new file mode 100644
index 0000000..ca9c89d
--- /dev/null
+++ b/BuildUnix/Gzip/Makefile.am
@@ -0,0 +1,34 @@
+## ======================================================================================
+## Copyright (c) 1999-2001 Palm, Inc. or its subsidiaries.
+## All rights reserved.
+## ======================================================================================
+
+##
+## makefile.am for poser-specific gzip code
+##
+SUFFIXES = .cpp
+
+VPATH = $(srcdir)/../../SrcShared/Gzip:
+
+## no subdir specific flags needed -- just go with globals
+LOCAL_CFLAGS =
+
+CFLAGS = $(POSER_CFLAGS) $(LOCAL_CFLAGS)
+CXXFLAGS = $(POSER_CXXFLAGS) $(LOCAL_CFLAGS)
+
+INCLUDES = -I$(srcdir)/../../SrcShared/Gzip
+
+noinst_LIBRARIES = libposergzip.a
+
+SRC_GZIP = bits.c \
+ crypt.h \
+ deflate.c \
+ gzip.h \
+ inflate.c \
+ lzw.h \
+ revision.h \
+ tailor.h \
+ trees.c \
+ util.c
+
+libposergzip_a_SOURCES = $(SRC_GZIP)