aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3b44e0f1..4dae6583 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,11 @@
#!/usr/bin/make -f
+
+# This target invoked by git-buildpackage using a clean hook, see gbp.conf
+prebuild:
+ git-dch --release --new-version=$(VERSION)
+ git commit -n debian/changelog \
+ -m "Automatically update debian/changelog for $(VERSION)"
+
%:
dh $@