aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Carl Worth <cworth@cworth.org>2010-04-16 08:49:09 -0700
committerGravatar Carl Worth <cworth@cworth.org>2010-04-16 09:32:46 -0700
commit2608bfe95f2c29ba568fa14904087882373971bc (patch)
treef0c0a1c372823da76bdc13cab9a2b8593fda00d7 /debian/rules
parent4906f6b9aec7947d609fe9127898e6a94dafd874 (diff)
debian: Add a gbp.conf to start using git-buildpackage
On Bdale Garbee's recommendation I'm switching from gitpkg, (which constructed a source tree but still required me to go run debuild), to git-buildpackage. I hadn't originally used git-buildpackage because it didn't seem to work without a configuration file, (where gitpkg was fine). Bdale was kind enough to point me to his fw/altos source at git.gag.com where I found an example gpb.conf file as well as a target in debian/rules to automatically update debian/changelog with the new version number.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 3b44e0f1..4dae6583 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,11 @@
#!/usr/bin/make -f
+
+# This target invoked by git-buildpackage using a clean hook, see gbp.conf
+prebuild:
+ git-dch --release --new-version=$(VERSION)
+ git commit -n debian/changelog \
+ -m "Automatically update debian/changelog for $(VERSION)"
+
%:
dh $@