aboutsummaryrefslogtreecommitdiffhomepage
path: root/contrib/notmuch-deliver/maildrop/numlib/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/notmuch-deliver/maildrop/numlib/configure.in')
-rw-r--r--contrib/notmuch-deliver/maildrop/numlib/configure.in41
1 files changed, 41 insertions, 0 deletions
diff --git a/contrib/notmuch-deliver/maildrop/numlib/configure.in b/contrib/notmuch-deliver/maildrop/numlib/configure.in
new file mode 100644
index 00000000..0c52a014
--- /dev/null
+++ b/contrib/notmuch-deliver/maildrop/numlib/configure.in
@@ -0,0 +1,41 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl $Id: configure.in,v 1.6 2004/12/10 02:34:46 mrsam Exp $
+dnl
+dnl Copyright 1998 - 2004 Double Precision, Inc. See COPYING for
+dnl distribution information.
+
+AC_PREREQ(2.59)
+AC_INIT(numlib, 0.10, courier-users@lists.sourceforge.net)
+
+>confdefs.h # Kill PACKAGE_ macros
+
+AC_CONFIG_SRCDIR([atotimet.c])
+AM_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([foreign no-define])
+
+dnl Checks for programs.
+AC_PROG_AWK
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_LIBTOOL
+
+if test "$GCC" = "yes"
+then
+ CFLAGS="$CFLAGS -Wall"
+fi
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+
+AC_CHECK_HEADERS(unistd.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_UID_T
+AC_TYPE_PID_T
+
+dnl Checks for library functions.
+
+AC_CHECK_FUNCS(setgroups initgroups)
+AC_OUTPUT(Makefile)