aboutsummaryrefslogtreecommitdiffhomepage
path: root/bindings/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/python/setup.py')
-rw-r--r--bindings/python/setup.py17
1 files changed, 5 insertions, 12 deletions
diff --git a/bindings/python/setup.py b/bindings/python/setup.py
index 16de76aa..286fd196 100644
--- a/bindings/python/setup.py
+++ b/bindings/python/setup.py
@@ -4,18 +4,11 @@ import os
import re
from distutils.core import setup
-def get_version():
- file = open('notmuch/__init__.py')
- try:
- for line in file:
- if re.match('__VERSION__\s*=\s*',line) != None:
- version = line.split('=', 1)[1]
- return eval(version, {}, {})
- finally:
- file.close()
- raise IOError('Unexpected end-of-file')
-
-__VERSION__=get_version()
+# get the notmuch version number without importing the notmuch module
+version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+ 'notmuch', 'version.py')
+execfile(version_file)
+assert __VERSION__, 'Failed to read the notmuch binding version number'
setup(name='notmuch',
version=__VERSION__,