aboutsummaryrefslogtreecommitdiffhomepage
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar David Bremner <bremner@debian.org>2011-06-19 15:09:46 -0300
committerGravatar David Bremner <bremner@debian.org>2011-06-23 07:13:32 -0300
commit0fdc28cd6bfb3aacc3594e8ff471258786f0de02 (patch)
tree10dfd22925709bd5bff26a763b65ce21fab7e9c4 /debian/rules
parentfba968dbfa806dc517fc55d1f28cf208f0316863 (diff)
debian: build package for python-bindings.
This uses dh_python2 (included with sufficiently recent versions of the python/python-all packages). python-all brings in all of the supported versions of python. The double calls to dh_auto_install and friends are to avoid looping over python versions ourselves.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 11 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index f7be2ca9..9ac190ea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,16 +3,26 @@
VERSION=$(shell dpkg-parsechangelog | sed -n 's/^Version:\([^-]*\)/\1/p')
%:
- dh $@
+ dh --with python2 $@
override_dh_auto_configure:
cp version debian/version.pre-build
echo $(VERSION) > version
dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
+override_dh_auto_build:
+ dh_auto_build
+ dh_auto_build --sourcedirectory bindings/python
+
override_dh_auto_clean:
-mv debian/version.pre-build version
dh_auto_clean
+ dh_auto_clean --sourcedirectory bindings/python
+
+override_dh_auto_install:
+ dh_auto_install
+ dh_auto_install --sourcedirectory bindings/python
+
override_dh_installdocs:
dh_installdocs
install -m644 vim/README debian/notmuch/usr/share/doc/notmuch/README.vim