aboutsummaryrefslogtreecommitdiffhomepage
path: root/bindings/python/setup.py
diff options
context:
space:
mode:
authorGravatar David Bremner <bremner@debian.org>2011-06-19 16:53:43 -0300
committerGravatar Sebastian Spaeth <Sebastian@SSpaeth.de>2011-06-20 09:45:43 +0200
commitc39b492c19ae667b2db2205b113d8378ddcb9093 (patch)
treeca0ec9afc13b939df9955c434a9d5ee28dfb0d1c /bindings/python/setup.py
parent12d6f90e77d975be721b6878bf6bbf914d65a369 (diff)
Do not import notmuch in setup.py.
Importing notmuch loads the notmuch shared library. When building without a system install of notmuch, this requires e.g. setting LD_LIBRARY_PATH for building and fails completely for cleaning.
Diffstat (limited to 'bindings/python/setup.py')
-rw-r--r--bindings/python/setup.py17
1 files changed, 16 insertions, 1 deletions
diff --git a/bindings/python/setup.py b/bindings/python/setup.py
index e4a3a251..1497bc43 100644
--- a/bindings/python/setup.py
+++ b/bindings/python/setup.py
@@ -1,7 +1,22 @@
#!/usr/bin/env python
+import os
+import re
from distutils.core import setup
-from notmuch import __VERSION__
+
+def get_version():
+ file = open('notmuch/__init__.py')
+ try:
+ for line in file:
+ if re.match('__VERSION__\s*=\s*',line) != None:
+ version = line.split('=', 1)[1]
+ return eval(version, {}, {})
+ finally:
+ file.close()
+ raise IOError('Unexpected end-of-file')
+
+__VERSION__=get_version()
+
setup(name='notmuch',
version=__VERSION__,
description='Python binding of the notmuch mail search and indexing library.',