aboutsummaryrefslogtreecommitdiffhomepage
path: root/bindings/python/setup.py
diff options
context:
space:
mode:
authorGravatar Sebastian Spaeth <Sebastian@SSpaeth.de>2011-08-23 09:30:49 +0200
committerGravatar Sebastian Spaeth <Sebastian@SSpaeth.de>2011-08-23 09:30:49 +0200
commit8826fc2d7b4e59afdd8cea06891a0c43245340c5 (patch)
tree5e9a15957de875d3819394f0cd1a3985e6422d92 /bindings/python/setup.py
parentf10ec87cc3ed9cbdb4e535ee6574c2a568c38b1d (diff)
python: Simplify setup.py
We were using a template setup.py which parsed __init__.py in complex ways just to find out the version number. Simply import notmuch and use __VERSION__ directly. Also adapt some wording and setup.py values while going through. Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'bindings/python/setup.py')
-rw-r--r--bindings/python/setup.py30
1 files changed, 10 insertions, 20 deletions
diff --git a/bindings/python/setup.py b/bindings/python/setup.py
index 1497bc43..19b65584 100644
--- a/bindings/python/setup.py
+++ b/bindings/python/setup.py
@@ -2,28 +2,19 @@
import os
import re
+import sys
from distutils.core import setup
-
-def get_version():
- file = open('notmuch/__init__.py')
- try:
- for line in file:
- if re.match('__VERSION__\s*=\s*',line) != None:
- version = line.split('=', 1)[1]
- return eval(version, {}, {})
- finally:
- file.close()
- raise IOError('Unexpected end-of-file')
-
-__VERSION__=get_version()
+dirname = os.path.dirname(os.path.abspath(__file__)) # Package's main folder
+sys.path.insert(0, dirname)
+import notmuch
setup(name='notmuch',
- version=__VERSION__,
+ version=notmuch.__VERSION__,
description='Python binding of the notmuch mail search and indexing library.',
author='Sebastian Spaeth',
author_email='Sebastian@SSpaeth.de',
url='http://notmuchmail.org/',
- download_url='http://notmuchmail.org/releases/notmuch-'+__VERSION__+'.tar.gz',
+ download_url='http://notmuchmail.org/releases/notmuch-'+ notmuch.__VERSION__+'.tar.gz',
packages=['notmuch'],
keywords = ["library", "email"],
long_description="""Overview
@@ -53,12 +44,11 @@ left of cnotmuch then.
Requirements
------------
-You need to have notmuch installed (or rather libnotmuch.so.1). The
-release version 0.3 should work fine. Also, notmuch makes use of the
-ctypes library, and has only been tested with python 2.5. It will not
-work on earlier python versions.
+You need to have notmuch installed (or rather libnotmuch.so.1). Also,
+notmuch makes use of the ctypes library, and has only been tested with
+python >= 2.5. It will not work on earlier python versions.
""",
- classifiers=['Development Status :: 2 - Pre-Alpha',
+ classifiers=['Development Status :: 3 - Alpha',
'Intended Audience :: Developers',
'License :: OSI Approved :: GNU General Public License (GPL)',
'Programming Language :: Python :: 2',