aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index fcd08da..da401ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,7 @@ include $(top_srcdir)/aminclude_static.am
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = scripts src man conf
EXTRA_DIST = autogen.sh ocb-license.html README.md COPYING.iOS
-BUILT_SOURCES = VERSION
+BUILT_SOURCES = VERSION.stamp
AM_DISTCHECK_CONFIGURE_FLAGS += --enable-compile-warnings=distcheck --enable-examples --enable-syslog
# AX_CODE_COVERAGE configuration
@@ -31,22 +31,22 @@ OCLINT_OPTIONS = -enable-global-analysis -max-priority-2=1000 -max-priority-3=10
-rc SHORT_VARIABLE_NAME=1 \
-rc MINIMUM_CASES_IN_SWITCH=2
-.PHONY: VERSION
+.PHONY: VERSION.stamp
-VERSION:
+VERSION.stamp:
@echo @PACKAGE_STRING@ > VERSION.dist
@set -e; if git describe --dirty --always > VERSION.git 2>&1 && \
[ -z `git rev-parse --show-prefix` ]; then \
- if ! diff -q VERSION.git VERSION > /dev/null 2>&1; then \
- mv -f VERSION.git VERSION; \
+ if ! diff -q VERSION.git VERSION.stamp > /dev/null 2>&1; then \
+ mv -f VERSION.git VERSION.stamp; \
fi; \
- elif ! diff -q VERSION.dist VERSION > /dev/null 2>&1; then \
- mv -f VERSION.dist VERSION; \
+ elif ! diff -q VERSION.dist VERSION.stamp > /dev/null 2>&1; then \
+ mv -f VERSION.dist VERSION.stamp; \
fi
@rm -f VERSION.dist VERSION.git
clean-local:
- @rm -rf VERSION cov-int mosh-coverity.txz compile_commands.json
+ @rm -rf VERSION.stamp cov-int mosh-coverity.txz compile_commands.json
# Linters and static checkers, for development only. Not included in
# build dependencies, and outside of Automake processing.