aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
authorGravatar Keegan McAllister <mcallister.keegan@gmail.com>2012-04-08 00:42:10 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-04-13 12:27:27 -0400
commitd2434d1a797454497c7294305cf243d64b6c28b0 (patch)
tree45295bb9d9ec16e7d4dc5544f2cb4d387526a7af /src/examples/Makefile.am
parent62b6137ff5b1c280ba99a0ba1b64b4a03cb3f779 (diff)
Check compiler support for -fno-default-inline and -pipe
clang was spewing warnings about the unrecognized -fno-default-inline. (Oddly, it warns only with -c, not when compiling directly to an executable.) For completeness we also check -pipe, even though clang is OK with that one. It should be fine to omit either flag. gcc -fno-default-inline drops the implicit 'inline' annotation on functions defined inside a class scope, but 'inline' is only a hint anyway. -fno-default-inline does not change linkage. -pipe is merely a compile speed optimization.
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 40421ad..9908b07 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -1,5 +1,5 @@
AM_CPPFLAGS = $(protobuf_CFLAGS)
-AM_CXXFLAGS = $(WARNING_CXXFLAGS) $(PICKY_CXXFLAGS) $(HARDEN_CFLAGS) -fno-default-inline -pipe
+AM_CXXFLAGS = $(WARNING_CXXFLAGS) $(PICKY_CXXFLAGS) $(HARDEN_CFLAGS) $(MISC_CXXFLAGS)
AM_LDFLAGS = $(HARDEN_LDFLAGS)
if BUILD_EXAMPLES