aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
authorGravatar Keegan McAllister <mcallister.keegan@gmail.com>2012-05-04 23:37:07 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-05-16 00:00:27 -0400
commit768d4ce797822926a1e67bb35b1f45ab3b455d51 (patch)
tree9fe3b5cd24908590b636ef13ce420dce121c6b6a /src/examples/Makefile.am
parentbb651581a7b4bdb5579c490fb4b44bade5edd32a (diff)
Make Select a singleton
It's going to manipulate process-global signal state, so multiple instances do not make sense.
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index b40bca6..c206eef 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -29,7 +29,7 @@ termemu_LDADD = ../terminal/libmoshterminal.a ../util/libmoshutil.a ../statesync
ntester_SOURCES = ntester.cc
ntester_CPPFLAGS = -I$(srcdir)/../util -I$(srcdir)/../statesync -I$(srcdir)/../terminal -I$(srcdir)/../network -I$(srcdir)/../crypto -I../protobufs $(protobuf_CFLAGS)
-ntester_LDADD = ../statesync/libmoshstatesync.a ../terminal/libmoshterminal.a ../network/libmoshnetwork.a ../crypto/libmoshcrypto.a ../protobufs/libmoshprotos.a -lutil -lm $(protobuf_LIBS)
+ntester_LDADD = ../statesync/libmoshstatesync.a ../terminal/libmoshterminal.a ../network/libmoshnetwork.a ../crypto/libmoshcrypto.a ../protobufs/libmoshprotos.a ../util/libmoshutil.a -lutil -lm $(protobuf_LIBS)
benchmark_SOURCES = benchmark.cc
benchmark_CPPFLAGS = -I$(srcdir)/../util -I$(srcdir)/../statesync -I$(srcdir)/../terminal -I../protobufs -I$(srcdir)/../frontend -I$(srcdir)/../crypto -I$(srcdir)/../network $(STDDJB_CPPFLAGS) $(protobuf_CFLAGS)