aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keegan McAllister <mcallister.keegan@gmail.com>2012-03-23 06:55:38 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-04-06 23:43:42 -0400
commitfe34cb380981c194b2ebdc37c34a2e947a8bb92d (patch)
treeb841b0356c619ece280688d25f37567ddaee266f /configure.ac
parent3b61581bcdfa046a5b15de356a9f8ad8b748ff9c (diff)
Create src/tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f2f7e92..b05a707 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,12 @@ AC_ARG_ENABLE([server],
[build_server="yes"])
AM_CONDITIONAL([BUILD_SERVER], [test x"$build_server" != xno])
+AC_ARG_ENABLE([tests],
+ [AS_HELP_STRING([--enable-tests], [Build tests])],
+ [build_tests="$enableval"],
+ [build_tests="no"])
+AM_CONDITIONAL([BUILD_TESTS], [test x"$build_tests" != xno])
+
AC_ARG_ENABLE([examples],
[AS_HELP_STRING([--enable-examples], [Build the miscellaneous programs in src/examples @<:@no@:>@])],
[build_examples="$enableval"],
@@ -200,6 +206,7 @@ AC_CONFIG_FILES([
src/util/Makefile
scripts/Makefile
src/examples/Makefile
+ src/tests/Makefile
man/Makefile
])
AC_OUTPUT