aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keith Winstein <keithw@mit.edu>2012-04-30 14:58:53 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-04-30 14:58:53 -0400
commite70254bad52bed809105a6c56e2f1e52643d329c (patch)
tree95506390f3bdbe4c865e81db7efa14ff4e7e977b /configure.ac
parent49fc21c8a3537d661ee3607777b532e3ce5103b9 (diff)
Add AM_PROG_AR for automake 1.12 (closes #250)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 215cf57..aed8604 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,10 @@ AC_PATH_PROG([PROTOC], [protoc], [])
AS_IF([test x"$PROTOC" = x],
[AC_MSG_ERROR([cannot find protoc, the Protocol Buffers compiler])])
+# automake 1.12 seems to require this, but automake 1.11 doesn't recognize it
+m4_pattern_allow([AM_PROG_AR])
+AM_PROG_AR
+
WARNING_CXXFLAGS=""
PICKY_CXXFLAGS=""
AC_ARG_ENABLE([compile-warnings],