aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keegan McAllister <mcallister.keegan@gmail.com>2012-04-10 22:00:48 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-04-11 02:45:15 -0400
commitc6751cfb92e5c5a4cdfc778398f74468123ccdf1 (patch)
tree91661d0b79745b68bc0866720f2e88dea7b68b10 /configure.ac
parentb4c47b77cf7ad12286509466fcbe9686adea55dc (diff)
configure.ac: Fix protoc check
AC_MSG_ERROR inside the variable assignment doesn't work properly. We get output like checking for protoc... ./configure: line 4524: is: command not found no and then the build continues (and fails) with PROTOC="". Closes #132 github pull request.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f96acec..24f5a13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,7 +13,9 @@ AC_CONFIG_HEADERS([config.h])
AC_PROG_CC
AC_PROG_CXX
AC_PROG_RANLIB
-AC_PATH_PROG([PROTOC], [protoc], [AC_MSG_ERROR([protoc is not found])])
+AC_PATH_PROG([PROTOC], [protoc], [])
+AS_IF([test x"$PROTOC" = x],
+ [AC_MSG_ERROR([cannot find protoc, the Protocol Buffers compiler])])
WARNING_CXXFLAGS=""
PICKY_CXXFLAGS=""