aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Anders Kaseorg <andersk@mit.edu>2012-04-17 02:50:29 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-04-22 16:14:28 -0400
commitb6736eb0a5db212a536e10bca241ea9a09ec56c3 (patch)
tree75634b92bebc05c15bd55dc3dc1cafb7717a1808 /configure.ac
parent76f5b593d9123f04721426f5759ba305b8ee970b (diff)
Use protobuf’s Gzip{Input,Output}Stream wrapper around zlib
This removes our direct zlib dependency (although of course protobuf still uses it internally), removes a fixed 4 MiB buffer and its corresponding limit on the terminal size, reduces some string copying, and deletes some code. Signed-off-by: Anders Kaseorg <andersk@mit.edu> (Closes #230.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e734cc9..ce59f2a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,8 +155,6 @@ AS_IF([test x"$with_utempter" != xno],
[AC_MSG_WARN([Unable to find libutempter; utmp entries will not be made.])],
[AC_MSG_ERROR([--with-utempter was given but libutempter was not found.])])])])
-AC_SEARCH_LIBS([compress], [z], , [AC_MSG_ERROR([Unable to find zlib.])])
-
AC_ARG_WITH([skalibs],
[AS_HELP_STRING([--with-skalibs[=DIR]],
[root directory of skalibs installation])],