aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keith Winstein <keithw@mit.edu>2012-05-23 05:31:56 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-05-23 06:08:45 -0400
commita7818c612c4908aa74b44b4e5163fe9f91fd424a (patch)
tree1eccbd5fafab38223d07d6a5fe758f030edcbe71 /configure.ac
parenteda48085ba7d624687289f15d970aec593fe1b59 (diff)
Install bash_completion rule and (optionally) UFW firewall profile
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 13e0ac1..d6e232c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,7 +135,7 @@ AC_ARG_ENABLE([server],
AM_CONDITIONAL([BUILD_SERVER], [test x"$build_server" != xno])
AC_ARG_ENABLE([tests],
- [AS_HELP_STRING([--enable-tests], [Build tests])],
+ [AS_HELP_STRING([--enable-tests], [Build tests @<:@no@:>@])],
[build_tests="$enableval"],
[build_tests="no"])
AM_CONDITIONAL([BUILD_TESTS], [test x"$build_tests" != xno])
@@ -146,6 +146,18 @@ AC_ARG_ENABLE([examples],
[build_examples="no"])
AM_CONDITIONAL([BUILD_EXAMPLES], [test x"$build_examples" != xno])
+AC_ARG_ENABLE([ufw],
+ [AS_HELP_STRING([--enable-ufw], [Install firewall profile for ufw (Uncomplicated Firewall) @<:@no@:>@])],
+ [install_ufw="$enableval"],
+ [install_ufw="no"])
+AM_CONDITIONAL([INSTALL_UFW], [test x"$install_ufw" != xno])
+
+AC_ARG_ENABLE([completion],
+ [AS_HELP_STRING([--enable-completion], [Install bash_completion rule @<:@yes@:>@])],
+ [install_completion="$enableval"],
+ [install_completion="yes"])
+AM_CONDITIONAL([INSTALL_COMPLETION], [test x"$install_completion" != xno])
+
# Checks for libraries.
AC_ARG_WITH([utempter],
[AS_HELP_STRING([--with-utempter], [write utmp entries using libutempter @<:@check@:>@])],
@@ -286,5 +298,6 @@ AC_CONFIG_FILES([
src/examples/Makefile
src/tests/Makefile
man/Makefile
+ conf/Makefile
])
AC_OUTPUT