aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keith Winstein <keithw@mit.edu>2012-03-31 15:07:28 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-03-31 15:07:28 -0400
commit9119fa1c7df778328a97b2e6891b54f98bf9ce89 (patch)
tree23302abc8f5fb9fcb01e463456f11fce8abe3846 /configure.ac
parent4f79778ca5296e7be71a54b6debfaae39470c587 (diff)
Add warning and check for IUTF8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9748cb..36e8cdc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,12 @@ AC_CHECK_DECL([__STDC_ISO_10646__],
[AC_MSG_WARN([C library doesn't advertise wchar_t is Unicode (OS X works anyway with workaround).])],
[[#include <wchar.h>]])
+AC_CHECK_DECL([IUTF8],
+ [AC_DEFINE([HAVE_IUTF8], [1],
+ [Define if IUTF8 is a defined termios mode.])],
+ [AC_MSG_WARN([No IUTF8 termios mode; character-erase of multibyte character sequence probably does not work properly in canonical mode on this platform.])],
+ [[#include <termios.h>]])
+
# Checks for protobuf
PKG_CHECK_MODULES([protobuf], [protobuf])