aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keith Winstein <keithw@mit.edu>2012-05-23 01:55:57 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-05-23 01:55:57 -0400
commit7700984bbb9dbc31a8efc57a414d2e7315a83240 (patch)
treecb2bce7468a4edd435fef20db2875be166669e76 /configure.ac
parenteca34ea0fddee951252005bf972e87ba323f63bd (diff)
Revert "Use protobuf's Gzip streams"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3151992..a177aad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,6 +158,8 @@ AS_IF([test x"$with_utempter" != xno],
[AC_MSG_WARN([Unable to find libutempter; utmp entries will not be made.])],
[AC_MSG_ERROR([--with-utempter was given but libutempter was not found.])])])])
+AC_SEARCH_LIBS([compress], [z], , [AC_MSG_ERROR([Unable to find zlib.])])
+
# Checks for header files.
AC_CHECK_HEADERS([arpa/inet.h fcntl.h langinfo.h limits.h locale.h netinet/in.h stddef.h stdint.h inttypes.h stdlib.h string.h sys/ioctl.h sys/resource.h sys/socket.h sys/stat.h sys/time.h termios.h unistd.h wchar.h wctype.h], [], [AC_MSG_ERROR([Missing required header file.])])