aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Brandon Black <blblack@gmail.com>2012-04-16 14:29:18 -0400
committerGravatar Brandon Black <blblack@gmail.com>2012-04-16 17:13:59 -0400
commit6c04291419ef5b10bce5aa50a2d7d4c482a7c880 (patch)
tree89fbe6b43a08d0123ce267276c30b73a85b51244 /configure.ac
parentbfa0999089cd3e3a57706d475b0e0821166735af (diff)
Fix ncurses detection at configure time
There appears to be a typo/thinko in the ncurses detection stuff in configure.ac. The fallout was that on a Linux host without ncurses-devel installed, "./configure" failed to find curses.h but claimed overall success, then the build failed later during make. This patch removes an extraneous comma, which seems to make it both fail and succeed correctly when it should.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f796de9..c44d28d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -235,7 +235,7 @@ PKG_CHECK_MODULES([TINFO], [tinfo], ,
[AX_CHECK_LIBRARY([TINFO], [curses.h], [tinfo],
[AC_SUBST([TINFO_CFLAGS], ["$TINFO_CPPFLAGS"])
AC_SUBST([TINFO_LIBS], ["$TINFO_LDFLAGS -ltinfo"])],
- [AX_CHECK_LIBRARY([TINFO], [curses.h], [ncurses], ,
+ [AX_CHECK_LIBRARY([TINFO], [curses.h], [ncurses],
[AC_SUBST([TINFO_CFLAGS], ["$TINFO_CPPFLAGS"])
AC_SUBST([TINFO_LIBS], ["$TINFO_LDFLAGS -lncurses"])],
[AC_MSG_ERROR([Unable to find libtinfo or libncurses])])])])])