aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keith Winstein <keithw@mit.edu>2012-04-23 22:49:32 -0400
committerGravatar Keith Winstein <keithw@mit.edu>2012-04-23 22:50:49 -0400
commit63459ed1c7db060b44c3ef639bd07c806ea3f737 (patch)
tree69c8ef99cca1a568c79ef6a9c6df19459d0ed69f /configure.ac
parent905176c2b9628a9837035338c89b35aa5a6cdf65 (diff)
Revert use of protobuf's Gzip streams.
Unfortunately some Red Hat-based distributions lack the required header. See https://bugzilla.redhat.com/show_bug.cgi?id=815587 This reverts commit 261a389a76d371034daae8f4cdcc1bdbc1b3b101. This reverts commit b6736eb0a5db212a536e10bca241ea9a09ec56c3.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 034ec13..60f63ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,8 @@ AS_IF([test x"$with_utempter" != xno],
[AC_MSG_WARN([Unable to find libutempter; utmp entries will not be made.])],
[AC_MSG_ERROR([--with-utempter was given but libutempter was not found.])])])])
+AC_SEARCH_LIBS([compress], [z], , [AC_MSG_ERROR([Unable to find zlib.])])
+
AC_ARG_WITH([skalibs],
[AS_HELP_STRING([--with-skalibs[=DIR]],
[root directory of skalibs installation])],