aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Joshua Pollack <jpollack@gmail.com>2012-04-15 13:07:20 -0700
committerGravatar Keith Winstein <keithw@mit.edu>2012-04-16 00:54:27 -0400
commit59e8364178f68f5f2308d1cbe2fa2975ca1d7f94 (patch)
tree64d4033629069ee537c02c9cd5889f2b7494f775 /configure.ac
parent25b0e0e8ab4276d8051fb621912d47cb39fd7d21 (diff)
Add support for Cygwin, which has curses headers in /usr/include/ncurses
[keithw -- applied style change from kmcallister] Closes #181.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 98f9b2b..d02062b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,7 +201,7 @@ AM_CONDITIONAL([COND_THIRD_LIBSTDDJB],
[test x"$have_signalfd" = xno && test x"$with_skalibs" = xno])
# Checks for header files.
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h langinfo.h limits.h locale.h netinet/in.h stddef.h stdint.h inttypes.h stdlib.h string.h sys/ioctl.h sys/resource.h sys/socket.h sys/time.h term.h termios.h unistd.h wchar.h wctype.h], [], [AC_MSG_ERROR([Missing required header file.])])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h langinfo.h limits.h locale.h netinet/in.h stddef.h stdint.h inttypes.h stdlib.h string.h sys/ioctl.h sys/resource.h sys/socket.h sys/time.h termios.h unistd.h wchar.h wctype.h], [], [AC_MSG_ERROR([Missing required header file.])])
AC_CHECK_HEADERS([pty.h util.h libutil.h])
AC_CHECK_HEADERS([endian.h sys/endian.h])
@@ -227,6 +227,9 @@ AC_CHECK_FUNCS([gettimeofday setrlimit inet_ntoa iswprint memchr memset nl_langi
AC_SEARCH_LIBS([clock_gettime], [rt], [AC_DEFINE([HAVE_CLOCK_GETTIME], [1], [Define if clock_gettime is available.])])
+AS_IF([test x"$__CYGWIN__" != x && test x"$TINFO_CPPFLAGS" = x],
+ [TINFO_CPPFLAGS="-I/usr/include/ncurses"])
+
PKG_CHECK_MODULES([TINFO], [tinfo], ,
[PKG_CHECK_MODULES([TINFO], [ncurses], ,
[AX_CHECK_LIBRARY([TINFO], [curses.h], [tinfo],