aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Keegan McAllister <mcallister.keegan@gmail.com>2012-03-17 05:36:42 -0400
committerGravatar Keegan McAllister <mcallister.keegan@gmail.com>2012-03-17 05:36:42 -0400
commit139bcbf9aef5423d9f34acd5f129ead7cd6de989 (patch)
tree199d300e465d4d2db22145396c2430a5c553e579 /configure.ac
parenta151ea15c2942ca527ea20d649b32ee517b40b2e (diff)
configure.ac: Add --enable-{client,server,examples}
These default respectively to yes, yes, no.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49eb146..898ac7b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,24 @@ AC_ARG_ENABLE([compile-warnings],
AC_SUBST([WARNING_CXXFLAGS])
AC_SUBST([PICKY_CXXFLAGS])
+AC_ARG_ENABLE([client],
+ [AS_HELP_STRING([--enable-client], [Build the mosh-client program @<:@yes@:>@])],
+ [build_client="$enableval"],
+ [build_client="yes"])
+AM_CONDITIONAL([BUILD_CLIENT], [test x"$build_client" != xno])
+
+AC_ARG_ENABLE([server],
+ [AS_HELP_STRING([--enable-server], [Build the mosh-server program @<:@yes@:>@])],
+ [build_server="$enableval"],
+ [build_server="yes"])
+AM_CONDITIONAL([BUILD_SERVER], [test x"$build_server" != xno])
+
+AC_ARG_ENABLE([examples],
+ [AS_HELP_STRING([--enable-examples], [Build the miscellaneous programs in src/examples @<:@no@:>@])],
+ [build_examples="$enableval"],
+ [build_examples="no"])
+AM_CONDITIONAL([BUILD_EXAMPLES], [test x"$build_examples" != xno])
+
# Checks for libraries.
AC_SEARCH_LIBS([utempter_remove_added_record], [utempter],
[AC_DEFINE([HAVE_UTEMPTER], [1],