aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Tom Judge <tjudge@sourcefire.com>2017-10-24 20:53:52 +0000
committerGravatar John Hood <cgull@glup.org>2017-11-05 11:54:43 -0500
commitab31b0f2711a11b53b22db8181713fe48cec0ce9 (patch)
treedc8ecfd97a737be0fe6427d42280a94dae3cb488 /Makefile.am
parente8331437d35debbb3670425db74a00c9ed0bd006 (diff)
Add syslog logging of connections
Log connection change events to syslog in the auth log, logging the PID, username and remote host. Also log session begin and end. Co-Authored-By: John Hood <cgull@glup.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 478a3da..2b9edf6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = scripts src man conf
EXTRA_DIST = autogen.sh ocb-license.html README.md COPYING.iOS
BUILT_SOURCES = version.h
-AM_DISTCHECK_CONFIGURE_FLAGS = --enable-compile-warnings=distcheck --enable-examples
+AM_DISTCHECK_CONFIGURE_FLAGS = --enable-compile-warnings=distcheck --enable-examples --enable-syslog
# non-Automake defines
CPPCHECK_FLAGS = --enable=all --template=gcc --force # -j8 disables unused function checking.