aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar John Hood <cgull@glup.org>2015-09-22 03:50:25 -0400
committerGravatar John Hood <cgull@glup.org>2015-10-03 03:46:17 -0400
commit29112b410a076d96a8b337017efc56b12f01ac73 (patch)
treed59fdce131eb438e7698013af0c87d7a206cbd78 /Makefile.am
parent5959342ac76e04792920b5cccffd67a840b2193d (diff)
configure: add --enable-warnings=distcheck
This disables -Werror everywhere but "Linux". The heuristic is rather crude.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c5cf249..1922ceb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@ SUBDIRS = src scripts man conf
EXTRA_DIST = autogen.sh ocb-license.html README.md COPYING.iOS
BUILT_SOURCES = version.h
CLANG_SCAN_BUILD = scan-build
-AM_DISTCHECK_CONFIGURE_FLAGS = --enable-compile-warnings=error --enable-examples
+AM_DISTCHECK_CONFIGURE_FLAGS = --enable-compile-warnings=distcheck --enable-examples
.PHONY: VERSION