aboutsummaryrefslogtreecommitdiffhomepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar John Hood <cgull@glup.org>2019-07-09 00:30:16 -0400
committerGravatar John Hood <cgull@glup.org>2020-05-17 23:55:09 -0400
commit12199114fe4234f791ef4c306163901643b40538 (patch)
tree716e52137529ebc9ee3d23430dbc7229b0c114e3 /Makefile.am
parent609fb91fbc6b2bcb2caa344d46e679c4fbb9f975 (diff)
Move generated includes to their own directory to avoid conflicts.
Fixes #1051, mosh fails to build on case-insensitive filesystems. XXX This isn't perfect because autoconf/automake drop several extra files in the directory anyway.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a0aa6b..100cbef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = scripts src man conf
EXTRA_DIST = autogen.sh ocb-license.html README.md COPYING.iOS
-BUILT_SOURCES = version.h
+BUILT_SOURCES = VERSION
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-compile-warnings=distcheck --enable-examples --enable-syslog
# non-Automake defines
@@ -29,20 +29,13 @@ VERSION:
fi
@rm -f VERSION.dist VERSION.git
-version.h: VERSION
- @printf '#define BUILD_VERSION "%s"\n' "$$(cat VERSION)" > version.h.new
- @set -e; if ! diff -q version.h version.h.new > /dev/null 2>&1; then \
- mv -f version.h.new version.h; \
- fi
- @rm -f version.h.new
-
clean-local:
- @rm -rf version.h VERSION cov-int mosh-coverity.txz compile_commands.json
+ @rm -rf VERSION cov-int mosh-coverity.txz compile_commands.json
# Linters and static checkers, for development only. Not included in
# build dependencies, and outside of Automake processing.
cppcheck:
- cppcheck $(CPPCHECK_FLAGS) -include config.h -I . \
+ cppcheck $(CPPCHECK_FLAGS) -include src/include/config.h -I src/include \
-I src/crypto -I src/frontend -I src/network -I src/protobufs \
-I src/statesync -I src/terminal -I src/util \
-I /usr/include -I /usr/include/google/protobuf -I/usr/include/openssl \