aboutsummaryrefslogtreecommitdiffhomepage
path: root/unittest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittest/CMakeLists.txt')
-rw-r--r--unittest/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/unittest/CMakeLists.txt b/unittest/CMakeLists.txt
new file mode 100644
index 00000000..3437518a
--- /dev/null
+++ b/unittest/CMakeLists.txt
@@ -0,0 +1,16 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}/../src/include
+ ${GLIB2_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${additional_lib_searchpath}
+)
+
+add_executable (unittestcpp unittest.cpp)
+target_link_libraries (
+ unittestcpp MailCore
+ ${ZLIB_LIBRARY} ${LIBETPAN_LIBRARY} ${LIBXML_LIBRARY} ${UCHARDET_LIBRARY} sasl2
+ ${TIDY_LIBRARY} ${CTEMPLATE_LIBRARY} ssl crypto ${linux_libraries} ${mac_libraries} ${ICU4C_LIBRARY}
+ ${GLIB2_LIBRARIES} ${FOUNDATIONFRAMEWORK} ${SECURITYFRAMEWORK} ${CORESERVICESFRAMEWORK}
+)