aboutsummaryrefslogtreecommitdiffhomepage
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 00000000..61fa7120
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,14 @@
+include_directories(${CMAKE_CURRENT_BINARY_DIR}/../src/include)
+link_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}/../Externals/ctemplate/lib
+ ${CMAKE_CURRENT_SOURCE_DIR}/../Externals/icu4c/lib
+ ${CMAKE_CURRENT_SOURCE_DIR}/../Externals/libetpan/lib
+)
+
+find_library(FOUNDATIONFRAMEWORK NAMES Foundation)
+find_library(SECURITYFRAMEWORK NAMES Security)
+find_library(CORESERVICESFRAMEWORK NAMES CoreServices)
+
+add_executable (tests main.mm test-all.mm)
+target_link_libraries (tests MailCore z etpan xml2 icudata icui18n icuuc sasl2 iconv tidy ctemplate ssl crypto
+ ${FOUNDATIONFRAMEWORK} ${SECURITYFRAMEWORK} ${CORESERVICESFRAMEWORK})