aboutsummaryrefslogtreecommitdiffhomepage
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hoa Dinh <dvh@google.com>2014-11-11 17:31:32 -0800
committerGravatar Hoa Dinh <dvh@google.com>2014-11-11 17:31:32 -0800
commitdab960778452211e15b4ea45c60b82973c468129 (patch)
tree7fd043d6422cd54c0ecc9a1ff429b8e4d545a185 /tests/CMakeLists.txt
parentdb59b2dae2cb60c0f5f0c2181228b59140e52c90 (diff)
build for GTK
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt17
1 files changed, 10 insertions, 7 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 289feb82..58bdcf70 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,14 +1,17 @@
-include_directories(${CMAKE_CURRENT_BINARY_DIR}/../src/include)
+pkg_check_modules (GLIB2 glib-2.0)
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR}/../src/include ${GLIB2_INCLUDE_DIRS})
link_directories(
${CMAKE_CURRENT_SOURCE_DIR}/../Externals/ctemplate-osx/lib
${CMAKE_CURRENT_SOURCE_DIR}/../Externals/uchardet-osx/lib
${CMAKE_CURRENT_SOURCE_DIR}/../Externals/libetpan-osx/lib
)
-find_library(FOUNDATIONFRAMEWORK NAMES Foundation)
-find_library(SECURITYFRAMEWORK NAMES Security)
-find_library(CORESERVICESFRAMEWORK NAMES CoreServices)
+#find_library(FOUNDATIONFRAMEWORK NAMES Foundation)
+#find_library(SECURITYFRAMEWORK NAMES Security)
+#find_library(CORESERVICESFRAMEWORK NAMES CoreServices)
+
+add_executable (tests main.cpp)
+target_link_libraries (tests MailCore z etpan xml2 uchardet sasl2 tidy ctemplate ssl crypto pthread icudata icui18n icuio icule iculx icutest icutu icuuc uuid ${GLIB2_LIBRARIES})
+
-add_executable (tests main.mm test-all.mm)
-target_link_libraries (tests MailCore z etpan xml2 uchardet sasl2 iconv tidy ctemplate ssl crypto
- ${FOUNDATIONFRAMEWORK} ${SECURITYFRAMEWORK} ${CORESERVICESFRAMEWORK})