aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hoa V. DINH <dinh.viet.hoa@gmail.com>2013-07-16 21:20:38 -0700
committerGravatar Hoa V. DINH <dinh.viet.hoa@gmail.com>2013-07-16 21:20:38 -0700
commitc045f956a74dd0068f75edafeecac70e7cef0953 (patch)
treec7af4f7f60be3ef8cc0360c9e9c770a3304294fe /src/CMakeLists.txt
parentf5e4186da2bc1c6d88582e8f2d4c6a236e278840 (diff)
Fixed #8: When the attachment is a folder, the folder is compressed and the attachment is the compressed file.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 02e53494..3c368309 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -133,6 +133,24 @@ else()
endif()
+# detect zlib
+
+find_path(ZLIB_INCLUDE_DIR
+ NAMES zlib.h
+ PATHS ${additional_includes}
+)
+find_library(ZLIB_LIBRARY
+ NAMES z
+ PATHS ${additional_lib_searchpath}
+)
+
+if(NOT ZLIB_INCLUDE_DIR OR NOT ZLIB_LIBRARY)
+ message(FATAL_ERROR "ERROR: Could not find zlib")
+else()
+ message(STATUS "Found zlib")
+endif()
+
+
file(GLOB_RECURSE
source_files
*.h