aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hoa V. Dinh <dinh.viet.hoa@gmail.com>2015-09-08 13:10:34 -0700
committerGravatar Hoa V. Dinh <dinh.viet.hoa@gmail.com>2015-09-08 13:10:34 -0700
commit859457d3a03a4a81eedb4f39caf3b667dee7a71c (patch)
tree4d5b8c76f00719fb7b42d5abfb024d001ec6e30c /CMakeLists.txt
parent2bdaf332652e6b2a7724dec4a9f1c886a70c04f7 (diff)
Fixed cmake file for Android
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a926538..6cf3307a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,6 +64,9 @@ if(NOT APPLE)
endif()
+IF(ANDROID)
+ message(STATUS "Android platform")
+ELSE()
# detect ctemplate
@@ -168,6 +171,8 @@ else()
message(STATUS "Found zlib")
endif()
+ENDIF() # Android platform
+
add_subdirectory (src)
add_subdirectory (tests)
add_subdirectory (unittest)