aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hoa V. DINH <dinh.viet.hoa@gmail.com>2016-03-08 00:07:45 -0800
committerGravatar Hoa V. DINH <dinh.viet.hoa@gmail.com>2016-03-08 23:47:23 -0800
commit1a1252198cbdaea49b19f6104c8555ede7a17913 (patch)
treeaa103998094191ccc203bc3a9c8d5a5728b8daf3 /CMakeLists.txt
parent9ba1127ed4e48763ff93c36860d0f53710668f54 (diff)
Fixed cmake build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6cf3307a..59866bf7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,12 +10,17 @@ IF(APPLE)
"${CMAKE_CURRENT_SOURCE_DIR}/Externals/libetpan-osx/lib"
)
+ execute_process(COMMAND xcrun --sdk macosx --show-sdk-path OUTPUT_VARIABLE sdkpath)
+ string(STRIP "${sdkpath}" sdkpath)
set(additional_includes
"${CMAKE_CURRENT_SOURCE_DIR}/Externals/ctemplate-osx/include"
"${CMAKE_CURRENT_SOURCE_DIR}/Externals/libetpan-osx/include"
/usr/include/tidy
/usr/include/libxml2
+ "${sdkpath}/usr/include/tidy"
+ "${sdkpath}/usr/include/libxml2"
)
+ message(STATUS "${additional_includes}")
set(mac_libraries iconv)