aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Christopher Rosell <chrippa@tanuki.se>2012-04-19 21:45:06 +0200
committerGravatar Christopher Rosell <chrippa@tanuki.se>2012-04-19 21:45:06 +0200
commit9663e667296278153ddb43c182d17be6eccc3e92 (patch)
treef24c1c9e95187736e3b184ffc298b39ca85b2897 /setup.py
parent85e95299580b42d076997e293e7e9c1dc258c834 (diff)
Only require argparse on Python <2.7 and <3.2.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 8 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8eb78c9..8d0670c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,15 @@
#!/usr/bin/env python3
from setuptools import setup, find_packages
+from sys import version_info
version = "0.1"
+deps = []
+
+# require argparse on Python <2.7 and <3.2
+if (version_info[0] == 2 and version_info[1] < 7) or \
+ (version_info[0] == 3 and version_info[1] < 2):
+ deps.append("argparse")
setup(name="livestreamer",
version=version,
@@ -15,7 +22,5 @@ setup(name="livestreamer",
entry_points={
"console_scripts": ['livestreamer=livestreamer.cli:main']
},
- install_requires=[
- 'argparse',
- ],
+ install_requires=deps
)