aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Christopher Rosell <chrippa@tanuki.se>2011-08-15 04:37:22 +0200
committerGravatar Christopher Rosell <chrippa@tanuki.se>2011-08-15 04:37:22 +0200
commit03ff523bfe2f2a3848470ce0ca46f2ef7116453c (patch)
treeeca46b63d5eee1b67c662c67874ac1f4a6bca5de /setup.py
Initial commit.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..b7262b7
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python3
+
+from setuptools import setup, find_packages
+
+version = "0.1"
+
+setup(name="livestreamer",
+ version=version,
+ description="Util to play various livestreaming services in custom player",
+ author="Christopher Rosell",
+ author_email="chrippa@tanuki.se",
+ license="BSD",
+ packages=["livestreamer", "livestreamer/plugins"],
+ package_dir={'': 'src'},
+ entry_points={
+ "console_scripts": ['livestreamer=livestreamer:main']
+ }
+)