aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar jeremy.shaw@linspireinc.com <unknown>2008-02-13 22:36:19 +0000
committerGravatar jeremy.shaw@linspireinc.com <unknown>2008-02-13 22:36:19 +0000
commite89d3e4df1778d4b4e7e6701a5e9950519f56018 (patch)
tree9c34e4181769603237fdc66b665ec9097b3d9227 /configure.ac
parentd93a1e7b2bc85d34cfa92558096008c3ee385981 (diff)
add AC_SYS_LARGEFILE check to configure.ac
As explained in this thread: http://www.haskell.org/pipermail/haskell-cafe/2008-February/039549.html getSymbolicLinkStatus (and possibly other functions) return completely bogus results. This is because hsc2hs returns the offsets for stat64, but the library is built such that it calls the 32 bit lstat call. I copied the AC_SYS_LARGEFILE from ghc's configure.ac. So, I believe the library should now properly autodetect whether your system has large file support and do the right thing more often. I suspect that this would still be buggy if ghc was built without large file support, but the library was built with it enabled. However, as long as AC_SYS_LARGEFILE returns the same results for 'ghc' and 'unix', things should be ok ?
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3618122..97a3f2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,10 @@ AC_SUBST([BUILD_PACKAGE_BOOL])
AC_C_CONST
+dnl ** Enable large file support. NB. do this before testing the type of
+dnl off_t, because it will affect the result of that test.
+AC_SYS_LARGEFILE
+
AC_CHECK_HEADERS([dirent.h fcntl.h grp.h limits.h pwd.h signal.h string.h])
AC_CHECK_HEADERS([sys/resource.h sys/stat.h sys/times.h sys/time.h])
AC_CHECK_HEADERS([sys/utsname.h sys/wait.h])