aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Ian Lynagh <igloo@earth.li>2011-01-01 20:11:50 +0000
committerGravatar Ian Lynagh <igloo@earth.li>2011-01-01 20:11:50 +0000
commitdd0178b4803924d8326224362611caad2d69e0e4 (patch)
tree7f8118b085e522c4cf02945bc8cdb9f4052251a0 /configure.ac
parentcc322963ec20df8c3e9067dca40e749c112f2878 (diff)
Proper autoconf test for sem_close's library; fixes trac #4523
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 3 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index a415609..346e1e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,18 +207,9 @@ AC_SUBST([EXTRA_LIBS])
# -{l,}pthread goo
AC_CANONICAL_TARGET
-PTHREAD_CFLAGS=
-PTHREAD_LDFLAGS=
-PTHREAD_LIBS=
-case "$host_os" in
-openbsd*)
- PTHREAD_CFLAGS=-pthread
- PTHREAD_LDFLAGS=-pthread
- ;;
-esac
-AC_SUBST(PTHREAD_CFLAGS)
-AC_SUBST(PTHREAD_LDFLAGS)
-AC_SUBST(PTHREAD_LIBS)
+AC_SEARCH_LIBS(sem_close, pthread,
+ [EXTRA_LIBS="$EXTRA_LIBS $ac_lib"],
+ [AC_MSG_NOTICE([Not found])])
AC_CONFIG_FILES([unix.buildinfo])