aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Ross Paterson <ross@soi.city.ac.uk>2009-06-16 14:06:11 +0000
committerGravatar Ross Paterson <ross@soi.city.ac.uk>2009-06-16 14:06:11 +0000
commitb507e58d18f3b1f54df5339f1c899ca6d0558022 (patch)
treec99d68331b62951c5e80e74614fc4863d32723a4 /configure.ac
parent27f3051c00152028dd93f6fd89ac040e85f4d163 (diff)
rename cache variables to keep recent autoconfs happy
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 696a495..4ce0a0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,12 +69,12 @@ dnl --- FIXME: /usr/include/unistd.h can't be right?
### On some systems usleep has no return value. If it does have one,
### we'd like to return it; otherwise, we'll fake it.
-AC_CACHE_CHECK([return type of usleep], cv_func_usleep_return_type,
+AC_CACHE_CHECK([return type of usleep], fptools_cv_func_usleep_return_type,
[AC_EGREP_HEADER(changequote(<, >)<void[ ]+usleep>changequote([, ]),
/usr/include/unistd.h,
- [cv_func_usleep_return_type=void],
- [cv_func_usleep_return_type=int])])
-case "$cv_func_usleep_return_type" in
+ [fptools_cv_func_usleep_return_type=void],
+ [fptools_cv_func_usleep_return_type=int])])
+case "$fptools_cv_func_usleep_return_type" in
"void" )
AC_DEFINE([USLEEP_RETURNS_VOID], [1], [Define if the system headers declare usleep to return void.])
;;
@@ -82,12 +82,12 @@ esac
### POSIX.1003.1 unsetenv returns 0 or -1 (EINVAL), but older implementations
### in common use return void.
-AC_CACHE_CHECK([return type of unsetenv], cv_func_unsetenv_return_type,
+AC_CACHE_CHECK([return type of unsetenv], fptools_cv_func_unsetenv_return_type,
[AC_EGREP_HEADER(changequote(<, >)<void[ ]+unsetenv>changequote([, ]),
/usr/include/stdlib.h,
- [cv_func_unsetenv_return_type=void],
- [cv_func_unsetenv_return_type=int])])
-case "$cv_func_unsetenv_return_type" in
+ [fptools_cv_func_unsetenv_return_type=void],
+ [fptools_cv_func_unsetenv_return_type=int])])
+case "$fptools_cv_func_unsetenv_return_type" in
"void" )
AC_DEFINE([UNSETENV_RETURNS_VOID], [1], [Define if stdlib.h declares unsetenv to return void.])
;;