aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Marios Titas <redneb@gmx.com>2012-06-13 02:52:03 -0400
committerGravatar Paolo Capriotti <p.capriotti@gmail.com>2012-07-17 16:42:13 +0100
commit9acb33c819356a49068ec041c38e438d335e9781 (patch)
tree470f4104a42dd64f2763aed6d34cea1d5611136c /configure.ac
parentba7961f118f42ba9db7e5fba017270a257852ff3 (diff)
Extract high resolution timestamps from FileStatus
Signed-off-by: Paolo Capriotti <p.capriotti@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ebf708d..9461452 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,22 @@ AC_CHECK_FUNCS([ptsname])
AC_CHECK_FUNCS([setitimer])
AC_CHECK_FUNCS([readdir_r])
+AC_CHECK_MEMBERS([struct stat.st_atim])
+AC_CHECK_MEMBERS([struct stat.st_mtim])
+AC_CHECK_MEMBERS([struct stat.st_ctim])
+AC_CHECK_MEMBERS([struct stat.st_atimespec])
+AC_CHECK_MEMBERS([struct stat.st_mtimespec])
+AC_CHECK_MEMBERS([struct stat.st_ctimespec])
+AC_CHECK_MEMBERS([struct stat.st_atimensec])
+AC_CHECK_MEMBERS([struct stat.st_mtimensec])
+AC_CHECK_MEMBERS([struct stat.st_ctimensec])
+AC_CHECK_MEMBERS([struct stat.st_atime_n])
+AC_CHECK_MEMBERS([struct stat.st_mtime_n])
+AC_CHECK_MEMBERS([struct stat.st_ctime_n])
+AC_CHECK_MEMBERS([struct stat.st_uatime])
+AC_CHECK_MEMBERS([struct stat.st_umtime])
+AC_CHECK_MEMBERS([struct stat.st_uctime])
+
# Additional temp functions
AC_CHECK_FUNCS([mkstemps mkdtemp])