aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Simon Marlow <marlowsd@gmail.com>2010-01-27 11:43:29 +0000
committerGravatar Simon Marlow <marlowsd@gmail.com>2010-01-27 11:43:29 +0000
commit6f74df238e660ffeb27d86feaf01222122a296eb (patch)
tree3c703b2316ee672d1a0e82984449a39baaa117b2 /configure.ac
parent433850cad14b869638557d27c6bdc63c668c1d87 (diff)
accept --with-cc to set the path to gcc (#2966)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bb171d2..a415609 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,11 @@ AC_INIT([Haskell unix package], [2.0], [libraries@haskell.org], [unix])
# Safety check: Ensure that we are in the correct source directory.
AC_CONFIG_SRCDIR([include/HsUnix.h])
+AC_ARG_WITH([cc],
+ [C compiler],
+ [CC=$withval])
+AC_PROG_CC()
+
AC_CONFIG_HEADERS([include/HsUnixConfig.h])
# Is this a Unix system?