aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Herbert Valerio Riedel <hvr@gnu.org>2015-12-06 17:06:41 +0100
committerGravatar Herbert Valerio Riedel <hvr@gnu.org>2015-12-06 17:06:41 +0100
commit147630c7c76bd9b947524ef140d21b9e81967c6e (patch)
treea3c1ea3964c45858512fea44481072e6ccf3ab4c /configure.ac
parent5740003e06f0c585460501514f3352f5e105c98c (diff)
Tweak use of AC_USE_SYSTEM_EXTENSIONS
This is a follow-up tweak to 5740003e06f0c585460501514f3352f5e105c98c It's better to move AC_USE_SYSTEM_EXTENSIONS after `AC_PROG_CC` as this avoids triggering edundant tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8738680..2c1b1ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,16 +1,17 @@
-AC_INIT([Haskell unix package], [2.0], [libraries@haskell.org], [unix])
AC_PREREQ([2.60])
+AC_INIT([Haskell unix package], [2.0], [libraries@haskell.org], [unix])
# Safety check: Ensure that we are in the correct source directory.
AC_CONFIG_SRCDIR([include/HsUnix.h])
-AC_USE_SYSTEM_EXTENSIONS
-
AC_ARG_WITH([cc],
[C compiler],
[CC=$withval])
AC_PROG_CC()
+dnl make extensions visible to allow feature-tests to detect them lateron
+AC_USE_SYSTEM_EXTENSIONS
+
AC_CONFIG_HEADERS([include/HsUnixConfig.h])
# Is this a Unix system?