aboutsummaryrefslogtreecommitdiffhomepage
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Igor Pashev <pashev.igor@gmail.com>2014-08-19 16:23:35 +0400
committerGravatar Herbert Valerio Riedel <hvr@gnu.org>2014-12-06 14:28:53 +0100
commit123fcba7125c3b94ad35c3d7dfe31c715a79a470 (patch)
tree4930490fba9dec22a76799d8796d213d1c596b6a /configure.ac
parent7222765c40868100e2527ec7c4a0832e68a786a0 (diff)
Do not blindly add libdl to extra libraries
On some systems dlopen() is available without libdl (illumos, solaris). Sometimes libdl.so cannot be loaded by runtime linker, see https://ghc.haskell.org/trac/ghc/ticket/8713 Closes #8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c10bf89..f519d19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,7 +186,7 @@ else
fi
# Avoid adding dl if absent or unneeded
-AC_CHECK_LIB(dl, dlopen, [EXTRA_LIBS="$EXTRA_LIBS dl"])
+AC_SEARCH_LIBS([dlopen], [dl], [EXTRA_LIBS="$EXTRA_LIBS $ac_lib"])
# -{l,}pthread goo
AC_CANONICAL_TARGET