aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/python/grpcio_reflection/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/python/grpcio_reflection/setup.py')
-rw-r--r--src/python/grpcio_reflection/setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/python/grpcio_reflection/setup.py b/src/python/grpcio_reflection/setup.py
index 20edbc4ec0..bed2311b59 100644
--- a/src/python/grpcio_reflection/setup.py
+++ b/src/python/grpcio_reflection/setup.py
@@ -25,6 +25,18 @@ os.chdir(os.path.dirname(os.path.abspath(__file__)))
import reflection_commands
import grpc_version
+CLASSIFIERS = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'License :: OSI Approved :: Apache Software License',
+],
+
PACKAGE_DIRECTORIES = {
'': '.',
}
@@ -48,6 +60,7 @@ setuptools.setup(
description='Standard Protobuf Reflection Service for gRPC',
author='The gRPC Authors',
author_email='grpc-io@googlegroups.com',
+ classifiers=CLASSIFIERS,
url='https://grpc.io',
package_dir=PACKAGE_DIRECTORIES,
packages=setuptools.find_packages('.'),