aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/python/grpcio_health_checking/setup.py
diff options
context:
space:
mode:
authorGravatar Craig Tiller <ctiller@google.com>2016-08-09 16:05:12 -0700
committerGravatar Craig Tiller <ctiller@google.com>2016-08-09 16:05:12 -0700
commit8a3df2ecbe5acd62e203ffdecaea216630619b83 (patch)
tree4a19f9eec7de131bc9fd81b61925c9e185dc7bec /src/python/grpcio_health_checking/setup.py
parentc919aff578cf59d4a1d610e1f7ed26db3aa601c3 (diff)
parent2f24f497c4e9578d9cc8a4a5606b3846c14e51d7 (diff)
Merge github.com:grpc/grpc into moovee
Diffstat (limited to 'src/python/grpcio_health_checking/setup.py')
-rw-r--r--src/python/grpcio_health_checking/setup.py23
1 files changed, 8 insertions, 15 deletions
diff --git a/src/python/grpcio_health_checking/setup.py b/src/python/grpcio_health_checking/setup.py
index 70b4575bf5..727d628885 100644
--- a/src/python/grpcio_health_checking/setup.py
+++ b/src/python/grpcio_health_checking/setup.py
@@ -30,49 +30,42 @@
"""Setup module for the GRPC Python package's optional health checking."""
import os
-import os.path
import sys
-from distutils import core as _core
import setuptools
-import grpc.tools.command
-
# Ensure we're in the proper directory whether or not we're being used by pip.
os.chdir(os.path.dirname(os.path.abspath(__file__)))
# Break import-style to ensure we can actually find our commands module.
import health_commands
-
-PACKAGES = (
- setuptools.find_packages('.')
-)
+import grpc_version
PACKAGE_DIRECTORIES = {
'': '.',
}
SETUP_REQUIRES = (
- 'grpcio-tools>=0.14.0',
+ 'grpcio-tools>=0.15.0',
)
INSTALL_REQUIRES = (
- 'grpcio>=0.13.1',
+ 'grpcio>=0.15.0',
)
COMMAND_CLASS = {
# Run preprocess from the repository *before* doing any packaging!
'preprocess': health_commands.CopyProtoModules,
-
- 'build_proto_modules': grpc.tools.command.BuildProtoModules,
- 'build_py': health_commands.BuildPy,
+ 'build_package_protos': health_commands.BuildPackageProtos,
}
setuptools.setup(
name='grpcio-health-checking',
- version='0.14.0',
- packages=list(PACKAGES),
+ version=grpc_version.VERSION,
+ license='3-clause BSD',
package_dir=PACKAGE_DIRECTORIES,
+ packages=setuptools.find_packages('.'),
+ namespace_packages=['grpc'],
install_requires=INSTALL_REQUIRES,
setup_requires=SETUP_REQUIRES,
cmdclass=COMMAND_CLASS