aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar David Garcia Quintas <dgq@google.com>2016-01-28 14:24:47 -0800
committerGravatar David Garcia Quintas <dgq@google.com>2016-01-28 14:39:54 -0800
commitfb018838590321a5e0635e0b499a33b31f71a0da (patch)
tree572ca6f66be48bbce78bd0b203b44fe3d5117524 /setup.py
parent610107cc3dced9fd39b24f9d6185e376b3375150 (diff)
parentddd91dbb42f6f52655738c6520548d04ea5f8468 (diff)
Merge branch 'master' of github.com:grpc/grpc into grpclb_api
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 11 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 4012397800..01e9180854 100644
--- a/setup.py
+++ b/setup.py
@@ -45,10 +45,11 @@ egg_info.manifest_maker.template = 'PYTHON-MANIFEST.in'
PYTHON_STEM = './src/python/grpcio'
CORE_INCLUDE = ('./include', '.',)
BORINGSSL_INCLUDE = ('./third_party/boringssl/include',)
+ZLIB_INCLUDE = ('./third_party/zlib',)
# Ensure we're in the proper directory whether or not we're being used by pip.
os.chdir(os.path.dirname(os.path.abspath(__file__)))
-sys.path.insert(0, PYTHON_STEM)
+sys.path.insert(0, os.path.abspath(PYTHON_STEM))
# Break import-style to ensure we can actually find our in-repo dependencies.
import commands
@@ -75,9 +76,9 @@ CYTHON_EXTENSION_PACKAGE_NAMES = ()
CYTHON_EXTENSION_MODULE_NAMES = ('grpc._cython.cygrpc',)
EXTENSION_INCLUDE_DIRECTORIES = (
- (PYTHON_STEM,) + CORE_INCLUDE + BORINGSSL_INCLUDE)
+ (PYTHON_STEM,) + CORE_INCLUDE + BORINGSSL_INCLUDE + ZLIB_INCLUDE)
-EXTENSION_LIBRARIES = ()
+EXTENSION_LIBRARIES = ('m',)
if not "darwin" in sys.platform:
EXTENSION_LIBRARIES += ('rt',)
@@ -118,8 +119,12 @@ PACKAGE_DIRECTORIES = {
}
INSTALL_REQUIRES = (
+ 'six>=1.10',
'enum34>=1.0.4',
'futures>=2.2.0',
+ # TODO(atash): eventually split the grpcio package into a metapackage
+ # depending on protobuf and the runtime component (independent of protobuf)
+ 'protobuf>=3.0.0a3',
)
SETUP_REQUIRES = (
@@ -127,6 +132,7 @@ SETUP_REQUIRES = (
) + INSTALL_REQUIRES
COMMAND_CLASS = {
+ 'install': commands.Install,
'doc': commands.SphinxDocumentation,
'build_proto_modules': commands.BuildProtoModules,
'build_project_metadata': commands.BuildProjectMetadata,
@@ -134,6 +140,7 @@ COMMAND_CLASS = {
'build_ext': commands.BuildExt,
'gather': commands.Gather,
'run_interop': commands.RunInterop,
+ 'bdist_egg_grpc_custom': commands.BdistEggCustomName,
}
# Ensure that package data is copied over before any commands have been run:
@@ -183,7 +190,7 @@ else:
setuptools.setup(
name='grpcio',
- version='0.12.0b5',
+ version='0.12.0b6',
license=LICENSE,
ext_modules=CYTHON_EXTENSION_MODULES,
packages=list(PACKAGES),