aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Yuchen Zeng <zyc@google.com>2016-08-11 21:21:32 -0700
committerGravatar Yuchen Zeng <zyc@google.com>2016-08-11 21:21:59 -0700
commitf64bf28e87356ca2ea26dfcfcb576de565180ad0 (patch)
tree5b0955cb4767a963aa6cf4997402fa7711ff756a /setup.py
parentd790dd6a5cb116245a8054692a1e10713d7512ac (diff)
Build c-ares without running ./configure
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 8 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 895fd663d6..e59f4286b4 100644
--- a/setup.py
+++ b/setup.py
@@ -52,11 +52,12 @@ PYTHON_STEM = os.path.join('src', 'python', 'grpcio')
CORE_INCLUDE = ('include', '.',)
BORINGSSL_INCLUDE = (os.path.join('third_party', 'boringssl', 'include'),)
ZLIB_INCLUDE = (os.path.join('third_party', 'zlib'),)
-CARES_INCLUDE = (os.path.join('third_party', 'c-ares'), os.path.join('src', 'c-ares'),)
-if "linux" in sys.platform:
- CARES_INCLUDE += (os.path.join('src', 'c-ares', 'config_linux'),)
-if "darwin" in sys.platform:
- CARES_INCLUDE += (os.path.join('src', 'c-ares', 'config_darwin'),)
+CARES_INCLUDE = (
+ os.path.join('third_party', 'c-ares'), os.path.join('src', 'c-ares'),)
+if 'linux' in sys.platform:
+ CARES_INCLUDE += (os.path.join('src', 'c-ares', 'config_linux'),)
+if 'darwin' in sys.platform:
+ CARES_INCLUDE += (os.path.join('src', 'c-ares', 'config_darwin'),)
# Ensure we're in the proper directory whether or not we're being used by pip.
os.chdir(os.path.dirname(os.path.abspath(__file__)))
@@ -134,7 +135,8 @@ CYTHON_HELPER_C_FILES = ()
CORE_C_FILES = tuple(grpc_core_dependencies.CORE_SOURCE_FILES)
EXTENSION_INCLUDE_DIRECTORIES = (
- (PYTHON_STEM,) + CORE_INCLUDE + BORINGSSL_INCLUDE + ZLIB_INCLUDE + CARES_INCLUDE)
+ (PYTHON_STEM,) + CORE_INCLUDE + BORINGSSL_INCLUDE + ZLIB_INCLUDE +
+ CARES_INCLUDE)
EXTENSION_LIBRARIES = ()
if "linux" in sys.platform: