aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Matt Kwong <mattkwong@google.com>2018-01-22 17:00:13 -0800
committerGravatar Matt Kwong <mattkwong@google.com>2018-01-26 18:21:50 -0800
commite7a60bd81294b84a90cfc5d2427bbee2cecfd18a (patch)
tree0e4a5b46097a13b35eb4db635855e731a41284fb /setup.py
parent654944bfebddcb83ba531078ea6f56ba71824a81 (diff)
Add NOMINMAX flag for Python Windows
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 73af9ebc4a..4f67f82275 100644
--- a/setup.py
+++ b/setup.py
@@ -165,7 +165,8 @@ if "win32" in sys.platform:
# TODO(zyc): Re-enble c-ares on x64 and x86 windows after fixing the
# ares_library_init compilation issue
DEFINE_MACROS += (('WIN32_LEAN_AND_MEAN', 1), ('CARES_STATICLIB', 1),
- ('GRPC_ARES', 0), ('NTDDI_VERSION', 0x06000000),)
+ ('GRPC_ARES', 0), ('NTDDI_VERSION', 0x06000000),
+ ('NOMINMAX', 1),)
if '64bit' in platform.architecture()[0]:
DEFINE_MACROS += (('MS_WIN64', 1),)
elif sys.version_info >= (3, 5):