aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Muxi Yan <muxi@users.noreply.github.com>2019-01-03 10:10:13 -0800
committerGravatar GitHub <noreply@github.com>2019-01-03 10:10:13 -0800
commite761e56630c9ca976eb09bb53f3f69842a0f04fd (patch)
tree3949194d99bdb7990e5a84429cbfb8065a40db8a /setup.py
parent8f5bda6de95f8948ab97084f2bbad6c6f5aec606 (diff)
parent6f083e112c509e4ef964b90eb1c3654033123878 (diff)
Merge pull request #17249 from muxi/16-to-32
Use 32 bit nanopb fields
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7bdfc99e24..7f58e7ca07 100644
--- a/setup.py
+++ b/setup.py
@@ -160,7 +160,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
EXTRA_ENV_COMPILE_ARGS += ' -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions'
elif "darwin" in sys.platform:
EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions'
-EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_16BIT'
+EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_32BIT'
if EXTRA_ENV_LINK_ARGS is None:
EXTRA_ENV_LINK_ARGS = ''