aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Yuchen Zeng <zyc@google.com>2016-08-16 23:41:47 -0700
committerGravatar Yuchen Zeng <zyc@google.com>2016-08-16 23:41:47 -0700
commite35d722988cf36962b38ee2a40acbe5ea9cad69f (patch)
treebf421f0a7dce7512914a6175618656c008102aec /setup.py
parentf456885e76a8d24c096bd5bd114ea6b2ac36ad81 (diff)
Trying to fix python on windows
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1ef03cff15..f7ba8911e2 100644
--- a/setup.py
+++ b/setup.py
@@ -150,7 +150,8 @@ DEFINE_MACROS = (
('OPENSSL_NO_ASM', 1), ('_WIN32_WINNT', 0x600),
('GPR_BACKWARDS_COMPATIBILITY_MODE', 1),)
if "win32" in sys.platform:
- DEFINE_MACROS += (('OPENSSL_WINDOWS', 1), ('WIN32_LEAN_AND_MEAN', 1),)
+ DEFINE_MACROS += (('OPENSSL_WINDOWS', 1), ('WIN32_LEAN_AND_MEAN', 1),
+ ('CARES_STATICLIB', 1),)
if '64bit' in platform.architecture()[0]:
DEFINE_MACROS += (('MS_WIN64', 1),)
else: