aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Jan Tattermusch <jtattermusch@google.com>2017-09-06 21:26:08 +0200
committerGravatar Jan Tattermusch <jtattermusch@google.com>2017-09-09 16:32:48 +0200
commitdc57fbd129b3d6712c6bd62e834568a0700632b5 (patch)
tree8135bf71ec92c1ca6d21b14dfec64a959e9dc014 /setup.py
parente8e9541715e5de2290641bca14a69fcc41b09513 (diff)
disable c-ares in python on windows x64 and x86
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 403c13562c..d3ea83488c 100644
--- a/setup.py
+++ b/setup.py
@@ -141,7 +141,7 @@ CYTHON_EXTENSION_MODULE_NAMES = ('grpc._cython.cygrpc',)
CYTHON_HELPER_C_FILES = ()
CORE_C_FILES = tuple(grpc_core_dependencies.CORE_SOURCE_FILES)
-if "win32" in sys.platform and "64bit" in platform.architecture()[0]:
+if "win32" in sys.platform:
CORE_C_FILES = filter(lambda x: 'third_party/cares' not in x, CORE_C_FILES)
EXTENSION_INCLUDE_DIRECTORIES = (
@@ -160,11 +160,12 @@ DEFINE_MACROS = (
('OPENSSL_NO_ASM', 1), ('_WIN32_WINNT', 0x600),
('GPR_BACKWARDS_COMPATIBILITY_MODE', 1),)
if "win32" in sys.platform:
- DEFINE_MACROS += (('WIN32_LEAN_AND_MEAN', 1), ('CARES_STATICLIB', 1),)
+ # TODO(zyc): Re-enble c-ares on x64 and x86 windows after fixing the
+ # ares_library_init compilation issue
+ DEFINE_MACROS += (('WIN32_LEAN_AND_MEAN', 1), ('CARES_STATICLIB', 1),
+ ('GRPC_ARES', 0),)
if '64bit' in platform.architecture()[0]:
- # TODO(zyc): Re-enble c-ares on x64 windows after fixing the
- # ares_library_init compilation issue
- DEFINE_MACROS += (('MS_WIN64', 1), ('GRPC_ARES', 0),)
+ DEFINE_MACROS += (('MS_WIN64', 1),)
elif sys.version_info >= (3, 5):
# For some reason, this is needed to get access to inet_pton/inet_ntop
# on msvc, but only for 32 bits