aboutsummaryrefslogtreecommitdiffhomepage
path: root/setup.py
diff options
context:
space:
mode:
authorGravatar Lidi Zheng <lidiz@google.com>2018-10-31 17:37:33 -0700
committerGravatar Lidi Zheng <lidiz@google.com>2018-11-06 18:07:03 -0800
commitcabe8d8f10387b49b52488989554d2946caee5aa (patch)
tree9499fd7abfd840dcfbafe169ca5452f08f52e11b /setup.py
parente4faafa5eb2b0b877a4b15822fb40101eea28a73 (diff)
New Python documentation generation
* Use templates instead of generating them every time * Theme changed * Add grpc_* modules * APIs grouped * No documentation for class members without docstring * Add docstring for status code
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 8845bd46d2..80e50ca643 100644
--- a/setup.py
+++ b/setup.py
@@ -283,8 +283,7 @@ if not PY3:
INSTALL_REQUIRES += ('futures>=2.2.0', 'enum34>=1.0.4')
SETUP_REQUIRES = INSTALL_REQUIRES + (
- 'sphinx>=1.3',
- 'sphinx_rtd_theme>=0.1.8',
+ 'Sphinx~=1.8.1',
'six>=1.10',
) if ENABLE_DOCUMENTATION_BUILD else ()